Term File Operations

Selecting/Deleting a Local Term File to Process

Because some users organize their local terms into multiple sets, the RELMA program provides a way for them to switch between the various sets they have created. On either the welcome or mapping screen, the user may choose the File > Change Local Term File option and bring up the screen shown in the figure below.

You may also delete a local term file by selecting the appropriate row and clicking the delete button at the button of the form.

You will not be able to delete the provided SAMPLE file.

To select a different Local Term File than the one currently loaded, simply click on the name of the Local Term File provided in the choice list and click the OK button. This will return you to the previous screen and you will begin working with the new Local Term File of local terms.

Viewing a Local Term File Summary

Just as Rome was not built in a day, complete local term files are rarely mapped in one session of RELMA. Some users reported it would be helpful to have a simple snapshot of their local term files so they could keep track of how many terms in the set had been mapped. Others reported it would be nice to see how many terms in their local term file were still unmapped. Merging the two ideas, the "View Local Term File Summary" menu option provides users with some very simple information about their local term files.

The summary form displays the total number of terms in the local term file, the number of terms currently mapped, the number of terms that are still unmapped and the number of terms that have a value in the Units field. Users may print this information out using the "Print" button provided on the form.

Viewing, Adding, and Editing Terms in a Local Term File

Selecting File > View/Add/Edit Terms in Local Term File from the menu activates the "View All Working Set Terms" tab as shown in the figure below. The local terms from the current Local Term File are displayed in a spreadsheet-style grid.

You cannot directly edit your local terms from the grid, but you can edit terms by double clicking a row in the grid. Alternately, you can select a term in the grid and click the "Edit Term in Local Term File" button at the top of the screen. You can delete local terms by selecting a term and clicking the "Delete Term from Local Term File" button. Choosing the "Add New Term to Local Term File" button at the top of the screen will initialize a dialog box and allow you to define a new term.

Manually editing the Local Term File of local terms should be done with caution. The RELMA program checks the data you are entering in a limited capacity, and it does not check for the addition of duplicate records or errors in data entry.

If you know the proper LOINC number, you can map your local terms directly from the grid. Just select one or more rows in the grid and click the "Map to LOINC" above the grid. You then be prompted to enter the LOINC number and an optional mapping comment. You can also use this technique to un-map one or more local terms. To un-map a local term, just leave the LOINC # box blank when requested and click the OK button.

Reporting Local Terms and Their LOINC Mappings

The File > Report Local Terms and Their LOINC Mappings menu option is used to print a report of your local terms. Selecting this menu option will activate the screen shown below. The window will be empty when it opens. Push the Preview button in order to view your report.

From here you can Preview or Print a report of the local terms in the current Local Term File by clicking on the corresponding buttons. You can also save the formatted report in either RTF or PDF formats.

If you save the report to a file, we recommend that you use the PDF format. The RTF support is incomplete and some formatting elements may not be saved.

The radio buttons in the "Records" group give you the ability to limit the records in the report to a subset of the entire Local Term File. Click the radio button that is most appropriate.

The radio buttons in the "Sorted By" group control the presentation of the selected terms in the report. You can choose to sort by the Battery Code, Battery Description, Test Code, Test Description, LOINC code or the original order of the terms at the time they were imported from a delimited file. All sorts are in ascending order only.

Exporting Local Terms and their LOINC Mappings

With this function you can export the contents of a Local Term File of local terms to a delimited text file or a Microsoft Excel spreadhseet. When you select this option, the dialog shown in the figure below appears.

"Term File to Export" is asking you to supply the name of the Local Term File that you wish to export. We have assumed above that the SAMPLE Local Term File is being exported.

The Export File Format allows you the option of exporting the Local Term File to a Microsoft Excel document or a delimited text file.

When the Export File Format option is set to delimited text file, you are presented with the option to set the field delimiter and the option to surround fields with double quotes. We suggest that you do not surround the fields with double quotes unless they prove to be useful in importing into some other program.

Next, you are given a series of checkboxes for the fields to be exported. By default, all fields are selected. Note, that a separate checkbox is included for the option of including the fields names as first row.

The File Name field is automatically populated with a suggested file name. This is constructed based upon the Local Term File name, the Export File Format, and the Field Delimiter. You may edit the file name directly in the associated text box or you may change the file name by selecting the Browse button.

If you wish to immediately open the file after export, check the Open When Finished checkbox to the left of the Export button.

Finally, click the Export button to write the data. The form's cursor is set to a waiting cursor while the Local Term File is exported. Upon completion. You may exit the form or perform another export.

Finding Local Terms Mapped to Deprecated/Discouraged LOINCs

Because LOINC codes are deprecated and/or discouraged over time, it is important for the user to discover deprecated/discouraged LOINC mappings within their Local Term Files and take steps to remap local terms to updated and different LOINC concepts. RELMA introduced a tool to assist in this endeavor in version 3.8. The tool scans a Local Term File of local terms and displays those local terms which have been mapped to deprecated or discouraged LOINCs. The tool then provides information about the deprecated/discouraged LOINC along with a suggested new LOINC to which the user may remap the local term. The figure below is a screenshot of the analysis tool.

If the tool scans your Local Term File, but does not find any local term to deprecated LOINC mappings, the following message will appear on your screen:

Clicking the OK button will close the tool and return you to the previous screen.

To remap a local code to the suggested LOINC, simply click the "Map to this LOINC" button. After you click this button, both LOINC terms will be suddenly grayed out, visually confirming the successful completion of the remapping.

Defining Default Specimens for Local Lab Sections

Lab Sections are an optional way to organize and classify groups of terms. If your place of business currently practices this method of organization, you may wish to transfer the classification into the RELMA program to make it easier to map LOINC terms to your local terms. Furthermore, individual lab sections can be assigned to associated LOINC systems to aid in searching for LOINC terms within the RELMA Program.

After choosing the Tools > Define Default Specimens for Local Lab Sections from the menu, you should see a screen similar to the one in the figure above. The figure shows that Hematology is the Lab Section selected with its associated LOINC System of BLD (blood) next to it.

To define a new Lab Section, click on the button labeled Add Lab Section. A new row will appear in the list to the far left labeled "Lab Sections:" and contain the word NEW. Replace the word NEW with the name of the desired Lab Section and press the Enter key.

To delete a Lab Section, highlight the Lab Section you wish to delete, right-click the mouse button, and choose 'Delete Lab Section'. When prompted, click the Yes button and the Lab Section will be permanently removed.

To assign a default LOINC Specimen to a Lab Section, highlight the Specimen name in the far right list labeled "LOINC SPECIMENS". Now press the button with the left arrow (less-than sign) and the system name should appear in the middle column. This completes the assignment.

To remove an assigned LOINC Specimen from a Lab Section, highlight the system name in the middle column. Now press the button with the right arrow (greater-than sign) and the Specimen should be removed from the middle column. This completes the removal process.

Assigned LOINC Specimen will appear in the Default Specimen text box on the mapping screen. When used in searching for LOINC terms, they will eliminate results that do not contain the same value in the System field in the LOINC database.

Defining Word Substitutions for Local Term File

The Tools > Define Word Substitutions for Local Term File menu option allows you to create a personalized dictionary of local words. Word translations are useful when you have a word in a local term name or description that is not the same as a related word in the LOINC database. For example, suppose you use the term ANT to mean ANTIBODY in your Local Term File of local terms. When you run the RELMA mapping option, ANT might be a local word in many of your terms, but LOINC won't recognize it because LOINC doesn't use ANT as an abbreviation for ANTIBODY. Therefore, you may wish to substitute ANTIBODY any time the local description in your Local Term File contains the word ANT.

If you choose the Tools > Define Word Substitutions for Local Term File menu option, you will see a screen similar to that shown in the figure below.

The combo box in the top left corner contains a list of words currently in your local file that have translations. The first time you use this feature, the words in the list are examples provided by Regenstrief Institute. To begin the process of translation, choose a local word from the combo box. In the example above, the user has selected the local word ALRG to translate. You can add new words/abbreviations to the Local Word box by clicking the Add New button. Type your new word into the Local Word box.

Below the Local Word combo box is a LOINC Translation text box into which you may type your translation. As you type a translation, a list box below is populated with words. We recommend that you choose one of these words as your local word translation. After selecting a word from the list, you can choose to save the translation by pressing the "Save" button along the bottom right part of the screen.

Sometimes it is helpful to ignore certain local words during searching. You may wish to check the "Ignore Local Word" box in the upper right corner of the screen. If you enable this box, each time the RELMA program sees your local word it will ignore it and pretend it does not exist.

You may also choose to limit your translation of a local word to a particular Local Term File if you have multiple sets defined. To limit a local word in this manner, choose the particular Local Term File from the combo box in the center right section of the screen in the figure above. When you search using local terms from that Local Term File in the future, your translation will occur. If you search using any other Local Term File, the translation will be ignored.

Any translations you create or edit are stored in the VocabularyMap table in your LMOF database. This information is used by the program for searching as shown in the figure below.

The next time you run the mapping program, the words (or abbreviations) that you have entered to the substitution table will be replaced with their associated expanded words. The following example shows how this might work.

Look at the Test Name box in the figure above. It says, "ALPHA-2-MACROGLOBULIN SER ALRG". Now look at the words from the local term description in the figure below.

Notice how the word "ALRG" in the local description has been translated to ALLERGY. Had this substitution not been done, the word would have been ALRG, an unknown word to RELMA, and the search would have yielded 0 results. However, a successful search is possible because the user created a record that contained an "alrg-allergy" pair for use as substitute words. (You do not need to worry about upper or lower case for the substitute words. The RELMA program takes care of that for you).

Edit a Substitute Word

If you wish to edit a substitute word and its associated expanded word: 1) select the substitute word from the combo box on the left side of the screen, 2) make whatever changes are necessary, and 3) click the Save button. The revised pair of words will be saved.

Delete a Substitute Word

If you find that you need to remove a substitute word from the table, select the offending word from the combo box and press the Delete button. You will need to confirm the deletion before the program will actually remove the word from the file.

Tag Management

The Tag Management system in RELMA is designed to help the user organize their local terms based upon a user-defined tag.

For instance, you may wish to organize your local terms by priority:

  • High
  • Medium
  • Low

Or, you could simply add a tag of "Submitted" to annotate that this record has been submitted as a LOINC request.

By using a tag system, you have the flexibility to define how you wish to group and organize your work.

Adding a Tag to a Local Term

  1. Open the Mapping Screen and Select the Mapping tab.
  2. On the form, locate and select Click to add tag.
  3. Enter the appropriate text and press Enter.

When tags exist, an autocomplete list will help you select pre-existing tags.

Adding a Tag to Multiple Local Terms

  1. Open the Mapping Screen and Select the View All Working Set Terms tab.
  2. Select one or many records contained by the grid.
  3. Right-click and hover over "Tag With"
  4. Select a pre-existing tag or enter a new tag using the "[ Add New ]" text box.

Removing a Tag from a Local Term

  1. Open the Mapping Screen and select the Mapping Tab
  2. Move your mouse over the tag to be deleted
  3. Locate and click the X to remove the tag

Searching for Local Terms by Tag(s)

The tagging feature of RELMA lets you quickly and easily filter the codes in your local working set to just the codes that you are interested in. RELMA provides three options for filtering a tag.

  • "No filter" - means that the tag will not be included in the filtering process
  • "Must be" - means that only local terms that have this tag will be displayed
  • "Must not be" - means that only local terms that DO NOT have this tag will be displayed

Tag filters are logically ANDed together. Only the Local Terms that contain the specific combination of "Must be" and "Must not be" tags will be shown. If you get in a situation where no local codes are shown, just click the "Clear Filter" button to set everything back to "No filter" and all of your local codes will be displayed.

Managing Tags

To open the form, select Tools and View/Add/Edit/Delete User Defined Tags from the top menu.

Adding a Tag

This method will not assign the new tag to any Local Term.

  1. Select the last row and enter the desired text

Deleting a Tag

Deleting tag(s) from this form will remove it from each Local Term it is assigned.

  • Select the [Delete] link for the associated row
  • Select the left most column on the desired row and press [Delete] on your keyboard

Editing a Tag

  1. Select the text column of the record you wish to edit
  2. Replace the text
  3. Press [TAB] on your keyboard or exit the form

Backup/Restore the Local Terms Database

To open, select File - Backup/Restore Local Terms Database from the main menu.

This form provides two features:

  • Backup

By pressing the Backup button a copy of the current local term database will be made.

  • Restore

By pressing the Restore button a copy of the current local term database will be made and the selected row in the grid will be restored. Note that the restoration process requires a restart of RELMA.

The number of backups maintained by RELMA can be set in the Local Terms Backup tab of User Preferences.

Knowledge Base

Users’ Guide

Search Syntax

RELMA

FAQ